#1  
Old 06-27-2020, 07:06 PM
dpoltzer's Avatar
dpoltzer dpoltzer is offline
Chief Ponti-yacker
 
Join Date: Dec 2012
Location: Atlanta, GA
Posts: 649
Default 1970 T/A lights on all the time?

Home stretch on the restoration and I have an electrical issue. Issue is that the external lights come on as soon as I install the battery cable on the battery post even though the headlight switch is in the "off" position. The headlight switch is new (Auto Zone #SW-144). I then replaced the HL switch with another new one and the same condition exists. I then installed a different High Beam switch I had laying around (Used) but that had no effect. One odd thing is that the HL switch has 3 detent positions rather than the typical 2. (parking lights and then Head lights). Does anyone know if this is the wrong switch or should I look in another direction? Thanks

__________________
1970 Formula 4 speed.1971 Formula 455. 1970 T/A
  #2  
Old 06-28-2020, 04:49 AM
Geoff Geoff is offline
Ultimate Warrior
 
Join Date: Jul 2005
Location: Australia
Posts: 2,298
Default

If you have a headlight relay, I would check that.

  #3  
Old 06-28-2020, 08:22 AM
"QUICK-SILVER" "QUICK-SILVER" is online now
Ultimate Warrior
 
Join Date: Feb 2008
Location: LaFayette Georgia
Posts: 4,920
Default

Need to find out where power is coming from.

I'd start by un-plugging the dimmer switch and probing the terminals with a test light. If green or tan shows to have power... It'll give us a direction to be looking. Blue wire should turn off and on with the headlight switch.

Clay

  #4  
Old 06-28-2020, 08:33 PM
Goatracer1 Goatracer1 is offline
Ultimate Warrior
 
Join Date: Oct 2003
Location: NH
Posts: 2,873
Default

Are you sure it's Auto Zone? There is no listing for SW-144. They list S427, S415, S427P and 55128. They have either 6,7 or 8 terminals. Do the lights go off if you unplug the switch? If they go off check to see that there is battery voltage to the correct terminal. If voltage is correct check continuity thru the switch. There should be infinite resistance with the switch off.

  #5  
Old 06-29-2020, 08:22 AM
dpoltzer's Avatar
dpoltzer dpoltzer is offline
Chief Ponti-yacker
 
Join Date: Dec 2012
Location: Atlanta, GA
Posts: 649
Default

it is an SW144 on the Auto zone site and it has 7 terminals/blades. My H.L. plug has 6 "live" terminals but does accommodate 7 blades. I will test dimmer switch wires later today.
Attached Thumbnails
Click image for larger version

Name:	sw 144   AZone.jpg
Views:	7
Size:	41.9 KB
ID:	543721  

__________________
1970 Formula 4 speed.1971 Formula 455. 1970 T/A
  #6  
Old 06-29-2020, 11:40 PM
Goatracer1 Goatracer1 is offline
Ultimate Warrior
 
Join Date: Oct 2003
Location: NH
Posts: 2,873
Default

It will NOT be the dimmer switch. The dimmer switch gets it's voltage from the head light switch and sends it either to low or high beams. With the head light switch disconnected there should be NO voltage to the dimmer switch.

  #7  
Old 06-30-2020, 02:16 PM
dpoltzer's Avatar
dpoltzer dpoltzer is offline
Chief Ponti-yacker
 
Join Date: Dec 2012
Location: Atlanta, GA
Posts: 649
Default

May or may not be related: volt gauge, oil pressure gauge and tach do not work as well. Could this be the printed circuit board and could all of these demons be related?

__________________
1970 Formula 4 speed.1971 Formula 455. 1970 T/A
  #8  
Old Today, 01:09 PM
dpoltzer's Avatar
dpoltzer dpoltzer is offline
Chief Ponti-yacker
 
Join Date: Dec 2012
Location: Atlanta, GA
Posts: 649
Default Update.

I disconnected the H.L. switch and when I connect up the battery, the marker lights and running lights are still on. Ideas?

__________________
1970 Formula 4 speed.1971 Formula 455. 1970 T/A
  #9  
Old Today, 03:59 PM
dpoltzer's Avatar
dpoltzer dpoltzer is offline
Chief Ponti-yacker
 
Join Date: Dec 2012
Location: Atlanta, GA
Posts: 649
Default update again.

I disconnected the turn signal switch and that now kills the parking lights etc. I will replace the T.S. switch and see if that cures the problem.

__________________
1970 Formula 4 speed.1971 Formula 455. 1970 T/A
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 06:31 PM.

 

About Us

The PY Online Forums is the largest online gathering of Pontiac enthusiasts anywhere in the world. Founded in 1991, it was also the first online forum for people to gather and talk about their Pontiacs. Since then, it has become the mecca of Pontiac technical data and knowledge that no other place can surpass.

 

Cold Case Radiators

Cold Case Radiators is a Max Performance company that produces high end aluminum performance radiators at a price point that won't break the bank. Polished and stamped tanks. 2 rows of 1" tubes. Lifetime Warranty.

GTOG8TA.com

GTOG8TA.com is a Max Performance company that manufacturers parts for the 04-06 GTO, 08-09 G8, and 93-02 Firebird/Trans Am platforms.

Copyright © 2017