#1  
Old 05-13-2022, 09:28 PM
Mook Mook is offline
Chief Ponti-yacker
 
Join Date: Mar 2004
Location: DC
Posts: 932
Default Help Please ….No turn signal indicator….😐

Installed dash, was so excited to see All the interior lights work as did the exterior lights….. except the left turn signal indicator …. The light blue wire from the turn signal is getting power on both aides of the connector, and blinks during operation the 2 light blue wires going into the instrument cluster is getting power, all the bulbs in the cluster work why don’t the left indicator illuminate when the flasher or turn signal is operating? Any assistance is appreciate thx!

  #2  
Old 05-13-2022, 09:35 PM
Stuart's Avatar
Stuart Stuart is offline
Moderator
 
Join Date: Apr 2003
Location: Minneapolis
Posts: 7,453
Default

What make, model and year is the car?

  #3  
Old 05-13-2022, 10:06 PM
Mook Mook is offline
Chief Ponti-yacker
 
Join Date: Mar 2004
Location: DC
Posts: 932
Default

Quote:
Originally Posted by Stuart View Post
What make, model and year is the car?
Sorry… 69 GTO…..

  #4  
Old 05-13-2022, 11:17 PM
Lemans64's Avatar
Lemans64 Lemans64 is offline
Ultimate Warrior
 
Join Date: Nov 2006
Location: Vancouver Island BC Canada
Posts: 1,683
Default

Do all the exterior lamps work correctly?? Flash and work as park lamps?

__________________
64 Lemans hardtop
4spd, buckets
  #5  
Old 05-14-2022, 04:38 AM
Mook Mook is offline
Chief Ponti-yacker
 
Join Date: Mar 2004
Location: DC
Posts: 932
Default

Yes…. Sir…

  #6  
Old 05-14-2022, 05:30 AM
dataway's Avatar
dataway dataway is offline
Ultimate Warrior
 
Join Date: Jan 2012
Location: Saratoga NY
Posts: 7,854
Default

When, if ever, does the left signal indicator LIGHT ... not flash, but does it ever light up?

Usually if it lights up and stays steady with the turn signal ON .. it's a problem with the exterior bulbs.

If it NEVER lights up it's usually a burnt out bulb, OR if you are using LEDs the bulb is installed 180 degrees out (wrong polarity). Could also be a bad printed circuit, dirty contacts on the bulb carrier etc.

__________________
I'm World's Best Hyperbolist !!
  #7  
Old 05-14-2022, 08:32 AM
Mook Mook is offline
Chief Ponti-yacker
 
Join Date: Mar 2004
Location: DC
Posts: 932
Default

The left turn signal indicator never lights up not for flasher not for blinker although the lights are blinking on the outside . I am thinking its something like the bulb … I pulled each bulb on that side of the cluster, not sure which one is actually for the indicator…they all light up on the workbench……. I even try to switch a few of the bulbs around to see if it was the contact, both indicators worked when I pulled the dash…..


Last edited by Mook; 05-14-2022 at 08:42 AM.
  #8  
Old 05-14-2022, 09:42 AM
"QUICK-SILVER" "QUICK-SILVER" is online now
Ultimate Warrior
 
Join Date: Feb 2008
Location: LaFayette Georgia
Posts: 5,406
Default

Terminal in the harmonica connector may need some tweaking so that it makes better contact with the printed circuit.

Clay

  #9  
Old 05-14-2022, 09:49 AM
Mook Mook is offline
Chief Ponti-yacker
 
Join Date: Mar 2004
Location: DC
Posts: 932
Default

Found an old cluster is this the Left turn signal bulb?

Also…. Turn signal barely worked with an original 552 flasher only worked with the type pictured… is that normal?? 🤔
Attached Thumbnails
Click image for larger version

Name:	63078847-4E98-4969-91E6-85C5BC085787.jpg
Views:	19
Size:	63.6 KB
ID:	590830   Click image for larger version

Name:	38FFCB11-D1F8-4173-8ECC-E165BCB497C1.jpg
Views:	15
Size:	65.8 KB
ID:	590831  

  #10  
Old 05-14-2022, 10:08 AM
Mook Mook is offline
Chief Ponti-yacker
 
Join Date: Mar 2004
Location: DC
Posts: 932
Default

Quote:
Originally Posted by "QUICK-SILVER" View Post
Terminal in the harmonica connector may need some tweaking so that it makes better contact with the printed circuit.

Clay
Hey Clay…. Funny was about to call you ….lol…. I was hoping that was not it🤦🏾*♂️

  #11  
Old Today, 02:13 PM
Vid's Avatar
Vid Vid is offline
Senior Member
 
Join Date: Dec 2020
Location: Reno, NV
Posts: 120
Default

Hey Mook I’m following this because I’m about to do the exact same project on the same year LeMans. Thanks


Sent from my iPhone using Tapatalk

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 04:28 PM.

 

About Us

The PY Online Forums is the largest online gathering of Pontiac enthusiasts anywhere in the world. Founded in 1991, it was also the first online forum for people to gather and talk about their Pontiacs. Since then, it has become the mecca of Pontiac technical data and knowledge that no other place can surpass.

 




Copyright © 2017